fufix 0.10.1 – Welcome Back, ClamAV!

"fufix" Banner

Die wichtigsten Veränderungen:

  • ClamAV integriert
  • ClamAV- und VirusTotal Scanner optional im fcc zuschaltbar
  • ClamAV Quarantäne in fcc
  • Debian Wheezy bietet keine Unterstützung für Apache2, da Apache v2.4 nicht mehr im Backports Repository
  • Erste Ubuntu 14.04 Unterstützung (aktiviert ein Apache2 PPA)
  • Apache2 mod_proxy_fcgi anstatt unfreiem mod_fastcgi für PHP-Integration
  • Spamassassin um Module Razor und Pyzor erweitert (danke mf3hdq@GitHub)
  • fcc Anhangsverwaltung übersichtlicher gestaltet
  • Deinstallations-Script mit „all“-Parameter aufrufen, um vollständig zu bereinigen
  • Einige Änderungen/Stabilisierungen an vielen Stellen

Update v0.10.1, 8. Mai: Systemabhängige Fehler bei der Installation behoben.

Ich danke vor allem Hendrik für seine aufopferungsvollen Tests! ;-)

Und wie gewohnt allen, die mir auf welche Art auch immer geholfen haben!

zu fufix

12 Antworten auf “fufix 0.10.1 – Welcome Back, ClamAV!

  1. alex

    Hallo,

    ich habe ./install.sh wie beschrieben gestartet. Allerdings passiert nichts. Ich sehe nur FUFIX und das wars, sonst keine Ausgaben.

    Irgendeine Idee was ich tun soll?

    Grüße!

  2. dh

    Hallo André,

    vielen Dank für deine Mühe und die ständigen Verbesserungen und Aktualisierungen.
    Ich hätte mal wieder eine Frage, und zwar:

    Wie kann ich nicht auf dem Mailserver angelegte Mailboxen auf einen anderen Server weiterleiten?
    Habe gelesen, dass das über die Postfix Transport Maps gehen soll, allerdings weiß ich nicht genau, wo ich in deinem Setup das genau einstellen muss.

    Wir haben ein Mailkonto test@domain1.de auf dem neuen Mailserver und ein Mailkonto alt@domain1.de auf dem alten Server. Wenn ich jetzt von test@domain1.de eine Mail an alt@domain1.de schicke, erhalte ich die Fehlermeldung

    „Senden der Nachricht an folgende Empfänger fehlgeschlagen: [„alt“ ] (550 – 550 5.1.1 : Recipient address rejected: User unknown in virtual mailbox table)“

    Wie realisiere ich das genau?

    Vielen Dank für deine Hilfe!

    Gruß
    dh

    1. André P. Autor

      Hi,
      du könntest Folgendes ausprobieren:
      – In der Datei /etc/postfix/main.cf die Zeile „reject_unlisted_sender“ entfernen oder auskommentieren (mit #).
      – Auf dem alten Server eine Transport Map erstellen mit einer Regel, die sich vorab authentifiziert. Bisschen schwer zu beschreiben und meiner Meinung nach für sowas zu viel Aufwand.
      Das Verhalten von Postfix ist schon richtig so. :-) Außer „mynetworks“ darf keiner mit einem Absender aus deiner Domäne versenden, wenn es den Absender nicht gibt oder er nicht eingeloggt ist.
      Alternativ könnte man den alten Server noch zu „mynetworks“ hinzufügen, aber das ist ohne Authentifizierung immer gefährlich. Im schlimmsten Fall (infizierte Scripts etc.) wird der alte Server als offenes Relay ausgenutzt. (Daher der zweite Vorschlag mit AUTH).
      Ich bevorzuge den ersten Vorschlag. Wenn ihr wirklich Spam von angeblich „eigenen“ Adressen bekommt, die es nicht gibt, dann sag Bescheid und ich helfe dir bei den Maps.

      Viele Grüße
      André

      1. dh

        Hallo Andre,

        danke für deine Tipps, habe deinen ersten Vorschlag mit „reject_unlisted_sender“ auskommentieren getestet, allerdings ohne Erfolg. Ebenso den alten Server zu mynetworks (der ist ohnehin nur intern erreichbar), aber auch ohne Erfolg.
        Zum Thema Transport Maps: das Problem ist, dass der alte Mailserver ein IBM Domino Server ist und ich weiß nicht, wie ich hier so etwas einrichten soll.

        Mein Hauptproblem ist, dass beide Mailserver die selbe Domain bedienen sollen, ich aber nicht von neu nach alt und umgekehrt senden kann, also nicht einmal im internen Netz.

        Hast du evtl. eine Idee wie man so eine Migration (mit der selben Domain) korrekt durchführt? Ich hatte schon überlegt, Aliase zu verwenden…
        Per MX Record geht es leider nicht, da die ja nur für den Serverausfall gedacht sind, und nicht für nicht vorhandene Postfächer…

        Vielen Dank + viele Gruesse
        dh

        1. dh

          Hallo Andre,

          also ich habs leider so nicht hinbekommen (trotz „postmap /etc/postfix/transport“ und postfix neustart was oben noch fehlt) … Nach einiger Recherche, wie das andere machen, bin ich auf eine Methode mit Subdomain, Alias und Weiterleitung gekommen. So sollte es klappen.

          Vielen Dank nochmal für deine Hilfe!

  3. Sascha V

    Hallo Andy,

    wäre es evtl. ein Umstand wenn du evtl. eine Groupware mit integrierst (OpenChange,Sogo)?
    Gerne wären wir bereit dafür was zu Spenden ;).

    LG Sascha

    Skype: Itsie2014

    1. Ludwig

      Hallo,

      gibt es eine Möglichkeit Apache 2.4 auf Debian Wheezy zu installieren, sodass ich Apache nutzen kann?

      Fehlermeldung: [ERR] – Unable to install Apache 2.4, please use Nginx or upgrade your distribution

      Viele Grüße

      1. André P. Autor

        Hi,
        du könntest versuchen, Apache 2.4 aus dem Jessie Repo zu installieren. Habe ich persönlich noch nicht gemacht, denke aber, dass es mit viel Aufwand möglich ist. Wahrscheinlich wird Systemd als Abhängigkeit installiert. Die Backports scheinen zur Zeit übrigens an einer neuen Version von „dpkg“ zu scheitern, wenn ich das richtig mitbekommen habe.

        Viele Grüße
        André

        1. Ludwig

          Hallo,

          Danke für deine Antwort!
          Ich habe zu Testzwecken einmal die fufix nginx Variante installiert, den Service gestoppt und anschließend Apache2 (2.2) installiert.
          Ngnix habe ich gelöscht. Da alle Daten bereits im var/www/ Ordner waren, kann ich alles bisher ohne Probleme mit Apache 2.2 nutzen. Ich kann keine Einschränkungen sehen. (Abgesehen davon das ich über „Domain.de/mail“ auf das Dashboard komme.) Oder wo sind die Einschränkungen / Fehler?

          Viele Grüße

          1. André P. Autor

            Hi,
            du kannst tatsächlich Apache 2.2 mit libapache2-mod-php5 benutzen. :-) Solange die PHP-Konfiguration sauber ist und mit Roundcube, fcc, Pfadmin etc. klarkommt, ist das kein Problem. Du kannst dir die PHP5-FPM Konfiguration aus fufix ja mal anschauen. Evtl. funktioniert das Umstellen der max. Nachrichtengröße im fcc nicht richtig. Wobei das Sache der Apache-Konfiguration ist, hierzu ebenfalls einfach mal in die fufix-Konfiguration schauen. Oder mailen/kommentieren. :-)
            Viele Grüße

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.